読者です 読者をやめる 読者になる 読者になる

真実の楽譜(フルスコア)

プログラム関係の忘備録になるはず

Android Developer Toolkit が 22.6.1 にアップデートできないときの対処

Android SDKマネージャでAndroid SDK Toolsのアップデートを行ったら、
Android Developer Toolkitも更新するように表示されたので、
更新の確認からEclipseプラグインの更新を行おうとしたところ

No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.ddms,22.6.1.v201403111859-1066720

とエラーが発生し、更新できない&Androidプロジェクト全てがビルドエラー状態に。
サーバー側にデータが置かれてないのか、パスのスペルミスなのかは不明ですが、
新規にAndroid Developer Toolkitをインストールさせることで解決できた。

手順

  1. [ヘルプ]→[新規ソフトウェアのインストール]をクリック
  2. [追加]ボタンをクリック
  3. ロケーションに「https://dl-ssl.google.com/android/eclipse/」を入力し[OK]をクリック
  4. リスト内に表示された項目にチェックを入れ、[次へ]をクリック
  5. インストールダイアログの指示に従いインストール